Upload Custom Product Image and Text

Hello Webflow!

I am trying to build a website similar to Sticker Mule. So users can upload a custom product name and image, then checkout that product.

Right now, a user fills out a form on Webflow, entering the sticker name and upload image link using Uploadcare. Then a product is created using Make.com Webflow integration.

From the form, a user is redirected to the Categories page, which is filtered to only show the newest product created. Then the user can view the product page and add it to their cart.

I’m not seeing a way to make the product a live item right away from the Create a Product Module, so I used Publish a Site to try and push it live.

Long story short, it’s not working exactly how I need it. It works, but it’s not publishing right away. Anyone have tips to fix this or a better way to upload custom images to a product?

Here is my site Read-Only: Webflow - Cup and the Cork

Nice build!

First off, Webflow recently limited the number of site publishes that you can make through the API. You may bump into issues with this approach if you haven’t already.

Second, some of those Modules are a bit lacking. Have you tried skipping that and making a direct API call using the HTTP module to that Webflow endpoint? Create Product & SKU

Thank you!

I actually have no idea what I’m doing, I’ve just watching a bunch of tutorials online and seeing what works lol

Hi Chris, Thank you for the feedback. So if I use a POST API call at the end, would that work?

Here I now have:

  • Watch Events that is a Webhook set to Form Submission
  • Filters by the specific form
  • Creates a product and the form values are creating the name and image for the product
  • Now I have a POST Make an API Call.

What do I put in the Body section for this module?

Thank you!

The point I was making is that your “Create a Product” module wasn’t working as you expected so you added one more module to republish the site.

You shouldn’t be doing that (republishing the site).

So my assumption was the “Create a Product” module wasn’t working for some reason and you could make an HTTP request to the Webflow API directly, instead.

But… looking at your latest screenshot makes me believe it is working as it should - and you don’t need that last republish site module.

Can you open up your “Create a Product” module and screenshot all of the settings? Multiple screenshots are fine, I just need to see what your settings are.

I believe I may know your issue.

While the products are successfully generated in Webflow, the process currently requires me to manually execute the scenario by clicking ‘Run’ in Make. Unfortunately, the products are not being automatically created when I submit a form without priorly selecting ‘Run’ in Make.

Sure thing, here are screenshots of all the modules and the settings that I’m using in Make.

BTW, I switch to a different site because my other one ran out of form submissions for testing

Thanks David.

Here’s some feedback to help you get past your issues…

The below module is why you are running out of forum submissions. This module is telling Webflow to continue using their native form submission feature.

Instead, what I like to do is bypass that and handle it myself. This gives me unlimited form submissions.

The negative (but some people view this as a positive) is those form submissions are no longer captured in Webflow within your project settings. You are responsible for capturing them yourself.

A common approach is to dump those to a free Airtable account.

Here’s a screencast showing you how to submit native Webflow forms with Make (Integromat) while bypassing the form submission limits.

You can also skip this filter with the method outlined in the link above if you want.

That doesn’t make sense.

In your screenshot for the second module, “Create a Product” it shows you referencing data that is sent into the first module “Watch Events” which is your form submission capture.

Without that data submitted from a form, your “Create a Product” module should not be working.

With what I’ve outlined above, you should be able to turn on your Make Scenario, have a user submit the form, capture that form submission in Make, and have Make create a product without using that last module “Publish a Site”.

To get this working…

I would simplify everything.

Step 1:

Start with a new Make Scenario and try to get a form submit working, with all the data you need, while skipping the Webflow form limits.

If this step doesn’t work report back here what didn’t work along with screenshots.

Step 2:

Create a second Make module that takes the data submitted in the form, and create the product. This should work, the product should be successfully created and live.

If this step doesn’t work report back here what didn’t work along with screenshots.

Hey Chris!

Thanks for your help, it really is appreciated.

One mistake I was making before was not selecting “Scheduling” on. So that’s why it wasn’t automatically doing it. Rookie mistake…

So, I kind of got things working, but now I just keep getting an “The operation timed out” error when creating an item in Webflow through Make. Looks like it’s now taking 40s to complete this task. Even though it eventually creates the item in Webflow, the form will give an error “Oops! Seems this timed out. Please try again.”

I love it when my own problems can be solved so easily :slight_smile:

Gosh, that’s super strange. My immediate reaction is that something is wonky on Webflows end. Temporary network issue, some software update gone bad on their end, etc…

Give it a few hours and see if corrects itself. If not…

Hop over to the Webflow API and make that same request through their API interface (just add your Webflow API token).

Is it working as expected from their interface but still slow on Makes end?

If so I would then reach out to Make support, outline that test you did, and ask them to look at their end to see if something isn’t working.

Report back here with your findings!

Looks like I got this working, but of course it’s still not working properly.

For the setup:
Webhook > Webflow Create a Product > Webflow Publish a Site > Webhook Response

It creates the product and gets published Live on the site, but it again times out on the site and gets sent to the 404 page. It’s not taking 40 seconds anymore; on Make, it says it’s only taking 4 seconds. If I refresh the page after 5 seconds, it redirects to the product page with the created product.

I think the problem is that it’s an e-commerce product, not a CMS item, and there is no Live option like in a CMS item. And since it’s publishing a site, that’s why it’s taking longer than expected. If I don’t have the Publish a Site module, then the product just sits in Webflow waiting to be published.

I then tried a Form Submit delay from Finsweet, but that’s not really working either…

Note: This does work perfectly for a CMS item.

I then tried Webflow Make an API Call for posting a product, but then I got an error:
“The operation failed with an error. [404] RouteNotFoundError: Route not found: /https:/api.webflow.com/sites/{siteID}/products” (I put the site ID from the Create Product & SKU Webflow page. So, I’m not sure why that isn’t working…

Yea that’s a bit confusing.

Overall, you will need to remove the “publish a site” module as that’ll just cause you more problems than it solves in the future.

But… I understand why you’re using it right now.

When I bump into these sorts of confusing issues I like to simplify everything. Peel away the layers and test small bits in isolation.

My guess is that there is an issue with the product and sku being created in the correct order. They appear to be dependent upon each other.

I’m not sure if its with Make, Webflow, or both. But to test I would use the Webflow API directly: Create Product & SKU

You can either add your Webflow Projects API key directly to this page and test from it, or choose an option like “shell” and test from their.

Either way, hit the Webflow API directly with all of the settings you have in Make and see what happens.

If that fails, now you have a “curl” statement (this is auto-generated for you under the shell option) to send to Webflow support.

They can dig into specifically why in your case this isn’t working.

Let me know the results!