Unwanted text squib

Can someone tell me why I can’t get rid of the text squib on the lower left side of this page? I don’t see it in navigator and it is not showing up on design page. Maybe a better question is how can I get into the html of the page to simply delete it?

Here is my site Read-Only: Webflow - mmp form
(how to share your site Read-Only link)

What have you tried so far?

It appears to be a title to a video. Have you checked into the settings of the video you plugged in?

Thanks Ali
I have deleted each element including video and it still persists and rebuilt each. I have also rebuilt the page from scratch and the text is imbedded in the body. No way to get to it other than going into html for the page. I know about adding html but is there any way to go into the full html, hunt down the text and deleting it? At this point I have deleted the page from the pages list and will rebuild the page with a different URL. It seems WF retains the memory of pages even tho they are deleted (?),