Unwanted side scroll on mobile

Hi there,

I have this weird side scroll space on mobile on my website www.novaliapatrimoine.fr

I even have the code snippet to hide the X overflow in the custom code settings.
I’ve looked at countless possible fixes.

Can’t find the problem. Any ideas ?


Here is my site Read-Only: Webflow - Novalia

Hi! :wave:

I think I can help. You have some elements with a class that’s going beyond the viewport on mobile.

It’s class: spacer-xsmall

I found at least a couple instances in your footer:
footer > footer-wrap > footer-center > Grid

The issue is the position is set to Absolute but it’s not contained within a relative element.

I was able to discover the element by going into developer tools and deleting elements, starting from the bottom to the top.

The overflow was removed as soon as I deleted the footer, isolating the culprit within.

I suspect with your spacer set to absolute, it’s not doing what you intend. Take a look at it.

Change the position or change the Auto from the absolute position settings all to 0.

I hope this helps!

~Your friendly neightbourhood Spinnemensch

You absolute legend !
I would’ve never found it myself.

Thanks a lot my man.

1 Like