Unable to link custom domain. "Invalid Domain" message everytime

Hello everybody. I just upgraded to the Basic Plan in order to publish my site to a custom domain. Everytime I enter the custom domain in the “Add Existing Domain” field I see an “Invalid Domain”.

Am I missing something? I already own the domain. I tried entering any domain in the box and still can only see the “Invalid Domain” popup.

Is Webflow currently experiencing technical problems with this?

What is the custom domain name? It may not be possible to link domain names containing ä, ü, ö, etc. characters.


I’ve tried using

and both lead to the same error

Might be because it was just registered, so it takes up to 72 hours for your domain name registrar to set it up and propagate the new domain to the domain name servers around the world.

Otherwise, you might need to contact support. Other users who encountered this issue was directed to do this. See Invalid Domain Error :((( trying to add custom domain - #2 by matthewpmunger