Unable to find binding option for element

Hi everyone,

I’m trying to follow along with the CMS tutorial. but when I try to bind the element (heading in this case) to my existing collection I’m unable to do that, because the field is just not there.

I’m referencing to this point in the tutorial

I don’t get this option to “get text from the collection” so I can’t bind it.

when I add a new collection to the site, the option for that collection is present, but for other static elements that I want to bind, it’s not there.

Any helps is super appreciated.

Thanks!


Here is my public share link: LINK
(how to access public share link)

Maybe in your collection the tittle is a rich text field so it can’t connect with regular text field in the designer…

Claudia, you’ll need to share a readonly link to your project.
The instructions are at the bottom of your post.

As Romauld said, the problem could be a mismatch between the element type you are binding, and the field type you are looking for.

But if you’re not seeing the purple menu at all, your element is not on a CMS page, or is not in a CMS collection list.

@memetican @Romuald_Jay

So, the problem is solved. The issue was that I was trying to bind elements on a non-CMS page. When I opened a CMS page everything worked as it should.

Thanks, both of you for your help! :slight_smile: