Unable to change size of designer extension

Hello, I’m working on a designer extension app & I’m trying to make the iFrame a bigger size. I tried changing the size variable in webflow.json like the docs say but nothing seems to change, even when I end & re-serve the app.

Any ideas?


What version is your Webflow CLI?

If you refresh your Designer instance and relaunch the Extension, do you see the new size?

I’m using the latest version 1.6.3 & yes I’ve tried refreshing the designer & there is no change in size.

Did you check everything from above? Maybe you missed something, and that’s why it doesn’t work properly.

Hey @lukev, have you tried using the large option? Does that one work? or is it just the “comfortable” size not working.

Yes, I tried testing with "size": "large" but still no change.
I’ve also tried manually resizing w/ the webflow.setExtensionSize("large") command & that doesn’t seem to be working either.

Thanks for checking! I’ve tested this on a local version on my end and it’s working for me.

How are you testing your App? Are you uploading the files manually or using the Development mode and running it locally?

If you change other content in your App, does it update in the Designer?

For settings like that, if your running it via npm run dev, you will need to end the dev session and run npm run dev again for it to update in the Designer.

Okay, solved the mystery!

First, the reason the preset size in webflow.json wasn’t working was because I was using ngrok as a proxy. I originally used a proxy because I was getting a CORS error, but disabling the Brave Shield on the Brave browser allowed me to use http://localhost:1337 & it worked.

Second, the reason webflow.setExtensionSize() wasn’t working was because for some reason the extension stopped updating even when clearing the cache. Changing the proxy url or just not using the proxy also fixed this.

1 Like

Awesome! Thanks so much for sharing your findings and solution!