Streaming live at 10am (PST)

Typekit fonts not displaying in Safari, Firefox

Hello all,
For my portfolio website, I used typekit for some custom fonts - Skolar, and Freight Text. They show up just fine on Chrome, but not on Safari or Firefox. I’ve just discovered this after more than a month of working on my site. Please help.


On Chrome, it is fine

On firefox and safari, it looks like this:

My font page looks like this:

Because these are web fonts, I cannot download them to my machine and upload as custom fonts… Please advise.

Anybody help me please? I need to share my site for an interview soon.

Hello @srile :smile:

I’m looking into this situation as we speak. Once I have an update, I’ll respond immediately.

Thanks for your patience.

Have you tried re-syncing your your typekit API?

For more information on this, please refer to this article:

1 Like

That’s it!

It works now! :smile:

I followed your link page, used a fresh token, and added another domain. Worked instantly.

Thank you very much. Outstandingly quick. I’m surprised that the link to typekit integration page didn’t show up in my searches. But its all good now.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.