Trying to Enable SSL using GoDaddy - Any Tips?


I am trying to use the new SSL feature to secure my website through Godaddy. It doesn’t seem to be working and when I go to the URL right now it shows

Anybody know what I am doing wrong ?



Here is my public share link: LINK
(how to access public share link) seems to be working fine.

Sorry. I was being generic. It is actually for my ATM machine business. is the URL. the ATM site is working on mobile with the SSL but not on any desktop computers. It just repeats the www.www please take a look.

Please let me know what you think.



Seems like it’s working fine as well. Perhaps clear your browser cache?

1 Like

Wow. That actually worked. I am shocked it was that simple. Thank you. I was stumped for a few hours as I thought I did everything correctly and still wasn’t able to resolve this. Awesome ! I appreciate your time and effort to help me out with this.

Any explanation as to why that would occur ? It is so strange.

Hi JibbyFlow,

Did you use Webflow’s SSL certificate or Go-Daddy’s?

I’m using GoDaddy as my registrar and DNS. I’m having trouble enabling Webflows new offered SSL Certificates…

Hoping you could share an explanation,


When you click Check Status in Webflow does it tell you everything is correct or is it asking for you to update the IP Address or the CName records still ?

If all is good. I cleared my browsers cache and it worked.

Let me know as much details and I will try to help.


It tells me things are not correct.

Partly because I’m using my root domain as non www. and Go-Daddy does not seem to support that with Webflow.

Setup your root domain as www in webflow. And then put correct IP in DNS in GoDaddy. And then add the proxy-ssl webflow server as cName in godaddy where it says www. Make sure you copy exact info from Webflow. It will state it when you enable ssl in webflow. And make sure to save changes in godaddy. And clear your browsers cache too.

Thanks Man, thanks for your time.


You need to delete some of dns record from your manage dns panel.

Might be your domain still has old record. Call godaddy they will tell you which dns record unnecessarily or delete all of them. Then add again which dns record webflow offer.

No problem. Did you figure it out ??

Not Yet -
But thank you…

I have my root domain as (non www) /… and godaddy & webflow does not play well together as I understand it . . . unless I make my root domain


Did you figure it out yet ?

Yeah I’m going to have to switch the DNS providers Webflow recommends - if I want to keep my prefered domain as NON -

Thanks for asking and for you help,

Hi Guys,

I’ve enabled SSL and followed the steps to change my settings in GoDaddy DNS Manager. Site works fine, and I’m not getting any error messages in the ‘Hosting’ tab of my Webflow dashboard.

But when I copy my website’s link from my browser it is still showing as http://

I thought that when SSL is enabled it shows as https:// ?

Any guidance would be much appreciated!


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.