Streaming live at 10am (PST)

Trouble with site publishing / Content appears different than domain

We’re having trouble with our page. It’s a podcast, and alongside each episode we want to show a transcript. We created a trigger button (the light blue one on the left, middle of the screen, text reads نص الحلقة so that when you click it, the transcripts appear and it’s not so overwhelming with pages of text on the screen right away.

We only realised recently, that even though we typed transcripts for 10 episodes in a single class (paragraph text), only 4 appear. All 10 appear in the editor, but only 4 appear on the live page. Even more confusing, we deleted the trigger button entirely thinking maybe that has something to do with it, and just copied all 10 transcripts as separate class paragraph texts that immediately appear when you open the webpage. They appear just fine in the editor, but the live webpage still shows the trigger light blue button and only 4 of the transcripts. (I recognise the page is in Arabic, but the numbers are in English so hopefully you can follow!)

Please advise (1) why what we see on the editor isn’t displaying on the live page, no matter how many times we click publish (2) how we can have all 10 transcripts displayed, preferably not automatically but after a user clicks the trigger button so the page doesn’t look so messy.


Here is my public share link: LINK
(how to access public share link)

Hi @kerningcultures, thanks for the question. I took a peek at the published site on and I can see the button. This site was last published 14 days ago, according to the publishing modal window in the designer or in Site Settings.

When I looked at the site on the domain:, the text appears as you have described, and without the button. The domain was last published 2 days ago, and this is likely the reason for the difference. The main custom domain has not yet been published with the changes.

I would republish your custom domains, see more how to do that here:

Make sure all domains are checked, and then publish. I hope this helps!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.