Trouble with embedded video from Vimeo

Hi all,

Webflow novice here…

I’ve been working on a site with a full screen video, whilst the site is working exactly as I’d hoped when I use a background video however I cannot get the resolution high enough using this method.

I embedded a video from Vimeo to increase the quality, however I cannot get it to fill the screen height and width even when set at 100vh/vw. Additonally, I have created a custom cursor which doesn’t seen to work when over an embedded video or a video block.

I was wondering if anyone knew how I can get my video to play (in high quality) as I have originally achieved using the video background element, with the working custom cursor.

I’m new to Webflow and have very little understanding of code so any help in as simple terms as possible would be much appreciated.


Here is my site Read-Only:

https://preview.webflow.com/preview/test-1-5f0582?utm_medium=preview_link&utm_source=designer&utm_content=test-1-5f0582&preview=6705a7316b02da4652d35673e2cae97f&workflow=preview

hi @justice in your position will be the best option to search “made in Webflow” examples to see how things are done. For issues with video your keyword should be “Vimeo” that display many examples that uses this player. You can also find some custom cursors examples but I believe there are some YT videos to written tutorials when you type “webflow custom cursor” to learn how things are done and how to build these.

Also this forum is full of solutions you can find when you use search input field.

Hope these informations will point you right direction

BTW: your link returns 404

1 Like

Hi Stan,

Thanks for your reply. I will take a look and see what I’ve missed re. Vimeo and hopefully custom cursors, I followed a few YT videos and as far as I can tell it should be working, I find the written instructions to sometimes be a bit too advanced in language for novices to follow sometimes…

I think I fixed the 404 now at least!