Trouble editing background image or gradient

Something went wrong with my styles on mobile view. I cannot change the background image ou gradient.
Also, a pop-up showed up informing that my site couldn’t be saved.

Could you please take a look?

I would really appreciate some help here…

Please post the public share link so we can look at the setup. That would help tons :smile:

Sorry, here it is:

Thanks in advanced.

That’s not the publicly shared link. Please read How to Enable a Webflow Share Link

Here it is:

Hope to have it right this time. :blush:

I got this when I tried to set the background. I’m guessing you did as well.

Did you email them like they asked?

Nope… I was trying to get some feedback at the forums.
I will send an email then. Thanks for taking time looking into this.

No problems. I know how difficult this can be at times and if I can pass on any of the little bits of help that I’ve gained here, I’m glad to do it.

You might want to mention if this was a purchased template or one build from scratch.

As a quick suggestion, maybe make a copy of the site and see if you can edit that copy, sometimes this can work.

1 Like

The issues were all solved.

Here is the final result:

Thanks Webflow team and @DragonDon.

1 Like

That’s great to hear!

Can you tell us what resolved the issue?

I duplicated the site, but the issue was still there.
So, as the Webflow team suggested, I replicated the classes with issues. I rename the header section into something else and then deleted the previous “header” class from the style manager.
From that I could give styles to my renamed header section.

Just to keep the same class, I then renamed it back again to header (as the style was deleted it assumed the “new” name and everything was back to normal.

The webflow support team just saved my day. I hope these tips from them can also help others.

Thanks for the update.

I’ve seen them happen many times before. Something ‘just doesn’t work’ but when you recreate it, ‘it works’. Seen the same thing happen on WordPress sites when I used Headway Themes (GUI) editor as well. Seems just like some sort of wrong/corrupted data gets stored somewhere, not recognized as being ‘invalid’ and thus produces an error result.

So, the fix is just what you did, essentially re-make the sections and then all is right with the world.

Glad things got sorted out!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.