Text Area in Forms Not Working

Hello, I can’t find a solution to a problem I have been having with forms. Every time I try filling out the form I’ve published to my website I don’t get anything written in the text areas back. I get what I write in my two “input” blocks. And I actually get what I write in the very last text area back, but it’s simply called “field”, not what I have named it.

I have no clue why this is happening. I’ve tried deleting the form and rebuilding it from scratch, but I get the same problems. I’ve attached screen shots below. Can anyone shed some light on this?






Here is my site Read-Only: [LINK] (https://preview.webflow.com/preview/park-bench?utm_medium=preview_link&utm_source=designer&utm_content=park-bench&preview=4bfe46aa023268d3a8f4d23799afa2b6&pageId=62ed6e8152cca74133c6458d&workflow=preview)
(how to share your site Read-Only link)

Did you try setting the Method to “Post”?

If don’t work I would recommend to use sheetmonkey.io

Thank you for the recommendation. I tried using post and it didn’t help. I have Sheet Monkey working now but I would prefer to use it as a back up. (Because I would rather keep my customised “success” state.)

Does anyone else have any solutions? Or can you notice anything off about my form?

Most probably the issue is that all your textarea elements have data-name=field. As they all have same name, you’re only getting the last one in your form submission.

You need to see how to change this attribute to textarea-specific value. But I am not sure why it would use data-name attribute instead of the name attribute. Probably some Webflow specific logic.

Ah OK. That’s really strange. Yeah, I have no idea how I would go about that. Thank you though!

I just tried renaming all of my textareas and the IDs for my textareas and that seems to have worked. I used different names for my textareas and my textarea IDs.

1 Like