Tech Issue, Image gear icon to change image is not working inside component. I have to unlink the component to edit it. Anyone else having this issue?

Hey Everyone,

I went to change an image inside a component, so I hit the gear icon and nothing happened. The widow doesn’t pop up that lets you change an image. I’m using Chrome and reset my browser, then I went over to Safari to try it, and neither worked. I then tried a different laptop and again the same thing happened. I unlinked the component and it let me change the image no problem. I’ve never had an issue editing images inside a component before. Is anyone else having this issue? Any tips would be appreciated.

Here is a video

Read only link: https://preview.webflow.com/preview/limonibelli?utm_medium=preview_link&utm_source=designer&utm_content=limonibelli&preview=813f8a530129321e52e5686d0c5bed84&pageId=6586652400518a27e26b7e5f&workflow=preview


Here is my site Read-Only: [LINK]1

Have you tried accessing the Image settings in the Settings tab with the Image selected? They should usually be accessible from there too. Not sure why the popover isn’t appearing for you.

1 Like

Thannk you!! I contact WF and they said their developers were fixing the issue. But I’ll try this next time if it happens again