Symbols with zero instances automatically deleted?

Would anyone confirm that symbols with zero instances are automatically deleted?

No, if you have this behavior I think it is a bug. :neutral_face:

Hi @uzzer the symbol is not deleted unless you delete the symbol from your Symbol settings:

Are you seeing different behavior on your end? If so, in which site and can you please share the site read-only link:

Thanks in advance!

Hi, thanks, here’s the share link:

Well, there used to be one or two symbols with zero instances and they are already gone. I can’t remember their names exactly :frowning:

Just tested it on your project…
I created a symbol - added it on another page
then delete both instances.

Now it displays the symbol name - and 0 instances.

So it seems to be working.

Other than the symbol I created - there are no other symbols with 0 instances.

Maybe preview and back - and if it’s there - get a screenshot so tech support can see it.

Hi @uzzer are you able to restore your site to a previous version where you had the symbols? Removing all instances of a symbol on the site canvas does not delete the symbol. To delete a Symbol you have to manually select the symbol and delete it (takes 3 clicks to delete). If you’re seeing otherwise, that sounds like very odd behavior.

If you see a preview of an older version of your site with the Symbol(s) still there can you please let me know which one? Please feel free to message me directly if you’re not able to share it publicly.

Here’s a screenshot of what I’m seeing in your Read-Only link:

Thank you all. I tried to reproduce the issue by creating and deleting a symbol and it worked correctly. So I can only guess it had been a special case with some of the previous zero instance symbols.

This topic was automatically closed after 60 days. New replies are no longer allowed.