SVGs and IE not working

I’m not sure it’s working on chrome and not IE.

What could be the problem here.

please advise.

thank you,
Jaime G.

As far as I know, only ie8 does not support svgs. What version of ie are you using?

I’m using IE 11.

I can view the SVG images in IE but the positioning is way off.


“IE9-11 desktop & mobile don’t properly scale SVG files. Adding height, width, viewBox, and CSS rules seem to be the best workaround.”

Is that your issue?

Positioning is the issue.

they scale and display perfectly.

try it in IE and then try it in Chrome. Chrome works perfect.

please help

Can you send a link to the published site? I want to see it outside of the designer and webflow doesn’t support ie11.

webflow doesn’t support IE 11?

I tried opening your link inside of a VM with ie11, and it said that it wasn’t supported. I’m on a mac, so the only way I can interface with windows is though browserstack.

That’s still the link to the editor. Do you have a link to the actual published site?

I think there’s something weird going on with those because they are absolutely positioned. I took a crack at moving some things around in your demo version, and I think it’ll fix your issue.

I made all of the svgs position: relative, wherever possible, and reorganized the groups of content a bit. They’re no longer looking for the tops and bottoms of a section or div, but are just placed in-line with the rest of the content.

I made .top-divider-white have a red background color also. Beyond that, I removed some paddings, as the height of the image could function as the padding.

Do you know if there’s a way to export the version from a preview setting somehow? I’m pretty sure that the way I have it set up will work, but I have no way to test it.

Yes actually, <-- running on wordpress

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.