Staging site not the same as in the designer?

Hi, can anyone workout why an element that shows within the designer but when published doesn’t?


Here is my site Read-Only: [LINK
(how to share your site Read-Only link)](Webflow - Current RecommerceIT)

hi @1960creative you should revisit your HTML structure, CSS and/or JS as you hiding element with class .splide that cause element with message be not visible even is rendered in DOM.

PS : please follow basic forum guide (that is pinned on top of each forum section) and provide live link when issue is on rendered site so people to not have to rip link to check live page from read-only :wink:

When posting please:

  1. Share your project’s Read-Only link AND live site’s Published link
  • The read-only link is a special url generated in the Dashboard to allow others to view your project in the Webflow Designer. How to get your project’s read-only link?
  • The published link is the <your-site> subdomain where you can view the live site with custom code running. It is important to share this link, as custom code does not run in the Designer.
  1. Upload as many screen shots/screen cast videos as possible to help others help you faster
  2. Add a description of what you’re trying to achieve, and/or post a link to a working example of what you’re trying to achieve
  3. Reply to users by tagging using the @ sign followed by their forum username like this: @username

Hi Stan, thank you for your time in looking into this matter. I can’t find how to fix this.

Here’s the share link again if that helps?


hi @1960creative I have point you where the problem is. Element is rendered in DOM but is hidden so take it as starting point to investigate how to solve it.

As your setup is nesting slides inside tabs and using custom JS it will be time consuming to at first understand your setup and guess where problem can be at second there is no option saving and checking changes on read-only it is not possible to give you exact solution.

IMO it is Splide CSS it self

  1. fix error

  2. as this rule come from Splide CSS check Splide docs how to change it or write custom CSS overrule this setting that is set on .splide

PS: Please read Guide once more time to get an idea what is difference between read only and Published links.