Streaming live at 10am (PST)

SSL Help for portfolio site

How do get the lock on my website damongoss.com? I already host through Webflow with a site plan. I click the SSL enable in Host setting and that never works. When I do do that it says “Issues Detected” Looks like your DNS provider doesn’t support this option. You can use option 1 above, or consider switching your DNS provider to DNSimple, DNS Made Easy, or Cloudflare. Learn more about setting up SSL on your root domain.

Someone please save me from this paradox


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Awesome work on your portfolio, @djgoss :grin:

I took a look at your DNS settings and you’ll need to replace your A records to the new ones:

Then set your “www” version of your domain as the default domain.

Then turn on SSL hosting and publish your site.

If you’re having any trouble with your DNS records or your custom domain, please contact our team at support@webflow.com and we’ll help guide you through the process.

Waldo found my answer perfectly, isn’t that ironic haha :grinning:

1 Like