(Solved) Shout out to all the geniuses! The custom cursor is always behind the content, images, and no solutions to it

Hi all geniuses,

I’ve tried to change the z-index on every object, but the cursor is still placed behind the images, which is quite confusing.

(simply changing the z-index for the cursor layer won’t work, because then I cannot select objects behind it)

Please help with your clever eye!

Appreciate your help!


Here is my public share link: https://preview.webflow.com/preview/yunhuang?utm_medium=preview_link&utm_source=designer&utm_content=yunhuang&preview=59906d70123e6f903c1298e1ba678ea1&pageId=611ad8ce436e2e641d987ba2&workflow=preview
([how to access public share link][2])

Bumping up the z-index on the Cursor div seems to fix this, no?


no, because then I cannot choose other objects behind the fixed layer…


Hi @Yun_Huang, thanks for the good question. If the cursor layer is set to the top layer, you are correct, you will not be able to select other elements natively underneath that layer, but you can also set the pointer events for the .cursor class in custom css to turn off the pointer events, to make the cursor layer behave with a “click-through” behavior.

I was trying to take a look at the site to test this, but it seems the read only link you shared is no longer valid.

From the screenshot it looks like the cursor layer has a class of “cursor”, so one possible solution (you will need to try it) is to add the following css to the head of the page in page settings, then publish the site.

.cursor {
     pointer-events: none;

The custom code may not render in the designer for this, but you can try that and see if putting the cursor layer to a higher z-index, then using the custom code if it works as expected on the published site.

Here is how to add custom code to the head and body of the page: Custom code in head and body tags | Webflow University

I hope this helps!

1 Like

Hi Dave,

Thank you so so much for the solution. It works now! I should probably start learning how to code :slight_smile: :rofl:

Appreciate webflow and the help, especially for creating this forum for us!


1 Like

Hi @Yun_Huang, glad I was able to help :slight_smile:

Stay awesome !

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.