Streaming live at 10am (PST)

Slider Autoplay not stop after click

Searhed forum - many requests for autoplay resume after user click… Not find code solution.

I have same request - need animated seqence of slides never stops - even after user click.

1 Like

As usual… Reply to myself :

In footer custom code

$(document).ready(function() {
	$('#sliderAuto').mousedown(function(e) {
		e.stopImmediatePropagation();
	});
})

My solution is for slider with no user control - arrows, etc

1 Like

I’m glad you are able to figure this out within two minutes, even before anyone had a chance to read your question! You have serious custom coding skills

1 Like

Yep!!! 15 years of coding :slight_smile: Ex Flash and Java engeeneer, forced to downgrade to JS that i left 11 years ago!!! Welcome to jQuery :slight_smile: Webflow its savier for me in the era of Flash denial.

1 Like

Hey @Reacol,

This solution is awesome!
But unfortunately my slider requires arrows, so the user can navigate it. But I don’t want the autoplay to be disabled every time the user navigates to the next slide. Is there any solution you might be aware of when there are arrows for navigating the slider as well?

Thanks a bunch!

Hi. Right now am not aware, but i’ll think of possible solutions…

You’re awesome! :raised_hands:

In the meantime I am challenging myself to find a solution. Will keep you updated :blush:

Hey Reacol!
I’m a complete noob at using Webflow, so sorry for this question.
Where exactley do I have to insert this code?

You need Footer code section.

$(document).ready(function () {
  setTimeout(function () {
  $('.w-slider').unbind('mousedown');
  $('.w-slider').unbind('touchstart');
  }, 500)
});

Hi Realcol,

I added the code to the Footer section but it doesn’t seem to be working for me.
Can you please have a quick look? Thanks!
M

http://upform-v1-5.webflow.io/

Have you published site after footer was added? I doesnt see any footer section inserted…
See working example : http://martp.webflow.io/

Thanks for checking, I had removed temporarily the code yesterday because it was displayed at the end of the page. I added the code again and it doesn’t work. By the way, there’s no slider in the link you sent.
Thanks again.

Hi @Reacol

I know this is quite an old thread, so I hope you don’t mind still being asked questions about this!

I’ve copied the code to the footer custom code but it doesn’t seem to have had any effect. I’m afraid I don’t know anything about writing code! Do you have any ideas of what might be the problem?

My preview site is: https://objekt-website-2020.webflow.io/

And my read only is: https://preview.webflow.com/preview/objekt-website-2020?utm_medium=preview_link&utm_source=designer&utm_content=objekt-website-2020&preview=feda8c3d044eb88c3ffaf7a4987852ba&mode=preview

Thanks so much!
Laura

I see you playing with pointer-events now… If you placed the code and it dosnt work that means that Webflow changed their inner-code and my old workaround do not work any more…
After you deplete all you attempts i can write a solution for your project - on a work-basis… As it will take a while to challenge this thing…

Yes I found someone had suggested the pointer code on another thread, but that’s not working for me either!