Sitemap XML not parsable LoCalisation

Automatic generated sitemap XML is not parsable by Google Search Console for domain hosted on .eu.

Domain has 2 locales:

  • .eu/at
  • .eu/de

.eu is not primary locale, our .eu/at directory is our primary local.

So we turned on ‘Create subdirectory’ in localisation settings

Also

  • Automatic URL routing is turned off.
  • We have sitemap autogenerated in dashboard settings.
  • In Localisation in dashboard - Time zone is set to Vienna, Austria
  • In Localisation in dashboard - language field is left empty
  • Canonical is set to .eu
  • There are no specific disallows for bots in robots.txt

www. version is the primary version of the domain

the sitemap URL is hosted on the www.sitenaam.eu/sitemap.xml and is visible for humans and bots (I tested this with sitemap XML parsers)

Problem pertains that GSC cannot fetch the sitemap. All GSC best practices according to the guidelines have been tried: using domain property, adding the sitemap.xml full URL, tried the hack of adding double // (.eu//sitemap.xml), and tried to put the sitemap URL in the Inspection tool.

All didn’t work.
Problem seems to be in that we do not have the root domain (.eu) without subdirectory selected as primary local, but instead have a subdirectory as primary locale. This adds a 302 browser redirect side-wide to every request of a URL that is .eu (without subdirectory) and it redirects it to the .eu/at equivalent. However, this 302 is not active on the sitemap.xml (which is hosted on the .eu/sitemap.xml) and this should not be an issue.

But still, the sitemap.xml is not fetchable by Google (GSC)

Last - business plan is active and we have purchased the local for .eu/de as well and published it.

Other supporting images

Schermafbeelding 2024-01-10 om 12.33.19

Please Help

Hi Mejunda, you didn’t share a link to your published site, so I’m not sure how you except the community to help. I’ll invest a little time anyway and make some wild guesses that might point you in the right direction.

According to the screenshot, the GSC error is “couldn’t fetch” which has nothing to do with parsing the sitemap. This is common for GSC. Resubmit your sitemap, and make certain the URL is correct so that you’re not asking GSC to redirect.

Also make certain you’ve republished your site since switching on automatic sitemap generation.

Webflow only publishes one sitemap per site, and it’s in the root, at /sitemap.xml.

Hi Memetican,

Thanks for responding and correcting. Unfortunately your direction is not solving it as I’ve tried those options multiple times already. Also, we add sitemap to domain property GSC (which is indeed only on .eu/sitemap.xml , at the root. )

I thought the view link wasn’t necessary considering the screenshots and all the provided information.

I can confirm to you i re-added the sitemap around 5 times, both in webflow, as well the URL submission in GSC. I am 100% sure that is not the issue.

For extra context to validate the above - we have also a Dutch domain hosted on www.sitename.nl - on a different entity (so it has nothing to do with this .eu locale)

In this NL site, everything around the sitemap generation and submission goes smooth and well. No issues.

It’s particularly the fetching of the sitemap.xml of the EU domain (with its locales) - as the context explains - that keeps giving this fetching error.

Anyone any other thoughts? or run into similar / same issue?

Hi Bart, there is nothing the community can help you solve.
You still haven’t provided any published site links.

It’s rather like saying “hey can you fix my car? it’s making a kachug sound.”
I’ve given you all I can, you might try GSC forums?

hi Memeetican,

I do feel a bit of a premature and condescending attitude that I do like to address. My client is very hesitant in sharing that so initially i preferred not doing that, hence all the very very detailed descriptions and images and screenshots (of the published site), especially since the read-only link does not provide ANY of this information, so my explanations will more likely be more of use than complaining about the view-only link.

Just would be very helpful if you could follow my line of thought and be a but more understanding, wouldn’t it?

Here is your view link.

To restate - my educated guess is Webflow is not able to host subdirectory locales as the primary local of a site as the 302 redirect site-wide will redirect any root level URL automatically to the primary directoy local (however, this is not the case for the sitemap, as a user you can still visit it, but Google still doesn’t fetch the sitemap )

Also, we have an exact same domain, but then in Dutch under .nl that is working all fine.

So, considering we have looked at almost anything (i presume) and given you all the information in detailed + the published link, I make a kind assumption here you might be able to help us with insights we have overlooked.

Thanks

Yes the read-only link doesn’t help here which is why I was asking for the published site link. I think I was able to identify it through the read-only link however.

This is the sitemap link you need to submit to GSC. Often when GSC struggles to parse a sitemap it’s because the link was submitted incorrectly and is redirecting.

https://www.informer.eu/sitemap.xml

Retry submitting this one, this works fine on my localized sites. You can see the content inside is correct including your default locale path.

If Google errors, try again, or just wait, it will generally pick it up when it has time to reprocess.

Hi Memetican,

Parsing? I thought you said we talked about Fetching?

Yeah … As I said about the sitemap - we tried various times, still after weeks (all all kinds of hacks we found online ) - no success:

To stress it one more time - all best practices have been triple checked for accuracy (all my dozens of other accounts, both this client and others) work fine.

It is a fetching (or parsing) issues of the fact that Google / GSC can’t reach it. This is a request to the browser / server where somehow something is not working due to the response code / user agent / localisation configuration of webflow (as described in my original post).

Let me know your thoughts

It’s evident that your understanding of the process here is rather limited, so I chose to use your own terminology.

image

You can check your sitemap yourself, and see that it both fetches and parses fine.

If you’ve done your GSC configuration correctly than you’re either having a Google problem, or a Webflow systems-level issue. Either way, the Webflow user community can’t help you.

And apparently no one else even wants to try. You should probably work on your tone. Being frustrated is normal, taking it out on the people who you’re requesting help from won’t get you very far in life.

haha this gets more funnier with the second.

I started about parsing, then you were ballsy enough to condescendingly mention its about fetching, and now you start talking about parsing.

Really, I explained from the start the most detailed description of what was going on, and all you could provide is condescending remarks about live site link, some basic ‘put this sitemap URL like this in GSC’ and that’s it

That’s why I nicely and respectfully kept asking and referring to what i thought is probably the source, namely perhaps something within Webflow or some technical thing I overlooked that goes beyond the basics. But instead I get hit with metaphors and condescending tones.

The audacity to say that I have a tone…haha luckily I can laugh about it