Seeking Assistance: Webflow Modal Close Button Doesn't Resume Scroll

Dear Webflow Team,

I hope this message finds you well. I’m reaching out for assistance regarding an issue I’ve encountered with the functionality of the modal close button in my Webflow project, particularly in conjunction with Lenis Scroll.

Issue Description: In my Webflow project, I’ve implemented Lenis Scroll for smooth scrolling functionality throughout the website. However, I’ve noticed that Lenis doesn’t integrate seamlessly with the native Webflow lightbox feature. Additionally, I’ve encountered challenges with ensuring that scrolling resumes smoothly after closing the lightbox modal.

What I’ve Tried: To address the issue, I attempted to implement custom JavaScript code to detect the modal close event and trigger scrolling to resume by adjusting the overflow property of the body element to 'auto'. Here’s the JavaScript code I’ve used:

javascriptCopy code

document.addEventListener('DOMContentLoaded', function() {
    var lightboxCloseButton = document.querySelector('.w-lightbox-control.w-lightbox-close');
    lightboxCloseButton.addEventListener('click', function() {
        document.body.style.overflow = 'auto';
    });
});

Error Messages and Additional Information: While inspecting the modal close button through the browser’s inspection panel, I was able to identify its HTML structure. However, even after adding custom JavaScript code to target the close button and resume scrolling, the desired behavior isn’t achieved.

Request for Assistance: I kindly request your guidance and support in resolving this issue. Given the integration of Lenis Scroll and the native Webflow lightbox, I’m looking for insights or solutions to ensure smooth scrolling resumes seamlessly after the modal is closed.

Moreover, I’ve added attributes to prevent background scrolling once the lightbox is engaged. However, the resume scroll functionality doesn’t seem to work correctly even after implementing custom JavaScript code to address it from the DOM.

Your assistance in resolving this issue would greatly enhance the user experience and functionality of my Webflow project. I’m not sure if I should leave a read-only link as I have removed the Lenis scroll attributes from the lightbox element and moved on from the feature. Just in case someone is able to fix this. I would be happy to test it with you.

Thank you for your attention to this matter. I look forward to your guidance and suggestions for resolving this issue.