Secure HTTPS Open Graph Failure

Hello. I can only seem to get my domain Open Graph image to appear with http, rather than the secure https. I’ve many many sites over the years and never experienced this.

Does it just need time? Or is there something I need to change?

Here is my site site 1
(how to share your site Read-Only link)

Hi @dougburnett, thanks for the post.

If you are using A Records to point the domain at Webflow, the WWW domain should be set as the default domain on the hosting tab of project settings.

See how to set the default domain: Set a default domain | Webflow University

Once the default domain is set, republish the site.

I hope this helps, let me know in case of any further trouble with that.

1 Like