Section Link not working on its own

Hello,

My website is one page but I’ve added sections. The nav link to the sections work fine but when I copy a section link in a browser, it goes to the homepage.

e.g section link: Gro Martian

As a result, the button that leads to that section doesn’t lead to that section. It shows the link in the browser but it doesn’t go anywhere.

Any help with this will be appreciated. I’ve scowered webflow forums but haven’t found a solution.

Here is my site Read-Only: http://gro-martian.webflow.io

Hi David! Please update your post and provide a read-only link to your Webflow project so we can take a look. Instructions are here. Thanks!

Hi Chris,

Sorry about that. Here it is:
https://preview.webflow.com/preview/gro-martian?utm_medium=preview_link&utm_source=designer&utm_content=gro-martian&preview=de9972f8e53a1249dbd256dde15668b3&workflow=preview

Hey, thanks for this. To be quite honest, I’m stumped. As far as I can tell here, you’ve got your sections set up properly. Your links are valid. I even created a new button with no classes or interactions, and those are not functioning either. I’m no expert, so maybe someone else can chime in, but in the meantime I’m going to recommend you open a support ticket with Webflow here.

If you’d like to try and work around this yourself, I could also suggest you constructing the button again, but this time, just make it a link block and style the same way as your button is. I would expect that to work fine, as that’s the same approach you’ve used for your navigation on the side.

hmmm, I tried setting up the link block as you suggested but it still doesn’t work. It seems as if it’s a problem with the section links, if they don’t lead to the section on their own then no button is going to either.

I’ll open a support ticket with Webflow and hopefully they can help. Thanks for trying!