Scroll doesn't work on mobile (not overflow problem)

Hello,
I can’t scroll on mobile on my search result page on mobile. There’s no overflow:hidden set. I can partially scroll down, but not back up or further down. Tested on Chrome, Safari and Firefox on iPhone. I’ve tried different settings and deleting every element at once. It seems that search result wrapper is the problem.

Any suggestion?
@cyberdave @PixelGeek


Here is my site Read-Only:
Webflow - PhotoRobot

Hi Matt! I opened up your project on my iPhone and am able to scroll just fine, it seems. Can you provide a link to a published version so I can take a look on a live site? Thanks!

Hi Chris! Thank You! Link to a live site is here:
https://www.photorobot.com/search?query=cube

Thanks, Matt! I think I’ve figured out your issue, for the most part. On another page ‘Stylesheet’ you have a class defined called ‘no-scroll’, which is enabling overflow:hidden for your body on mobile. The strange part is that if I look for this class inside the styles manager, it even says that the class is not used on the Search Results page, but I can clearly see it being applied when I inspect the element on a mobile browser (more on how I did this here).

So, my solution to you would be to just delete this class, and I’d expect your issue to be solved. If this isn’t an option for you, an alternative workaround could be to add the below code snippet to an HTML embed on the Search Results page, or in the page’s custom code (before ). Please let me know which method you go with, and if the issue is resolved for you.

<style type="text/css">
    .no-scroll {
          overflow: visible !important;
          }
</style>

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.