Streaming live at 10am (PST)

Safari Displaying Webfows Favicon

I published my site to my Webflow hosting plan and the Favicon in Safari is still showing Webflows icon in the URL field even though I’ve uploaded my own in the project setting menu. My Favicon shows up in Chrome but not Safari.

Anyone experience this? If so, any ideas how to swap it out. I hosted with Webflow in order to white label the site.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

It’s showing on the page load I just tested. If it is still not updated for you now, you should try clearing your browser cache.

Hey Webdev. I’m having issues with displaying my favicon in Safari as well. I’ve dumped my cache countless times and restarted everything. I added code to the head tag to cover all apple-touch sizes as well as other icon sizes. I’ve even tried the Safari mask code to use a monochromatic icon, but all I get is a blue circle - no icon. I’m running Safari 12.1.

My read only link is https://preview.webflow.com/preview/cp-content-cpsite2?utm_medium=preview_link&utm_source=designer&utm_content=cp-content-cpsite2&preview=da5067445f161861432092499ad77907&mode=preview

And your published site URL is?

Live site is Cyberpolicy.com

<link href="insure.cyberpolicy.com/favicon.ico?v=rMBexrYpqY" rel="shortcut icon" type="image/x-icon">

That is a relative link which results in a 404. Should be changed to https://insure

I’ve updated that and dumped cache a few times. Still doesn’t update Safari. Is this kind of update take time to propagate?

Should not if the icon is not in the cache. I just checked on an iPad and did not get one. Maybe after dinner I can swing back and take a look at the code. No promises.

Here is a rather complete article regarding favicons that may help you resolve your issue.

Hey Jeff. How can I get my .ico file to the root of my site? I’m thinking that’s the issue. Is there any FTP access I can use? Or can your team place my ico file at the root of my site? Right now I’ve loaded the .ico file through my project settings, and that places it in the assets folder. Should Safari pick that up even though it’s not at root? I’m not sure what else to try.

It’s working on Safari v 14. There is no way to add a file to the root. As for my team, it’s all me. I don’t work for WF.

cyberico

Just tested Safari 13.1 and works there. Make sure you have enabled show icons in tabs.

I didn’t realize you didn’t work for WF. Thank you for taking time with me.

I have gotten the monochromatic icon showing in Safari. Do you know how I can get a full color version to display? Before I added the safari-pinned-tab.svg, I wasn’t getting an icon in Safari at all. Not sure where to go from here.