Streaming live at 10am (PST)

[Resolved] Page doesn't load properly when you load a URL with an anchor link included

As title suggests, if i refresh the page when an anchor link is on the URL, the hero part of my site doesn’t load.

This is currently live on my my site. For example, if you browse to this site, and the scroll up, the whole top part of the home page doesn’t load:

This is a live error so I need help quickly, as this site goes ona wide launch tomorrow.

Share link:

Hi @irishbuckley

Thanks so much for posting and letting us know about this issue. This definitely looks like weird behavior.

I have reported this issue to the team and we are investigating. I’ll post back here as soon as I have more information.

I was only able to see the error the first time I visited that URL with the anchor link:

However, when I refreshed the page, the hero section loaded as expected. Is this the same behavior you are seeing?

​Thanks in advance for your patience while we investigate!

Hi @Brando,

Yeah it happens the first time you load from an acnhor link. I’ve lined this directly, but if you were to load the home page and then click the very first White button (which is an anchor link) and then refresh, you get the same experience.

I imagine this is an edge case, but could be seen if people vist my site having autofiled the URL.

Happens across any page where there is an achor link

1 Like

Thanks for that confirmation and extra info @irishbuckley! I’ll respond when I have more information!

So one thing I noticed.

When I initially click the link to the section that you provided, I experienced the behavior you were describing. When I refreshed it loaded the hero section as well (in chrome). When I tried on Firefox, I experienced the same behavior except I had to click the nav to go back to the main page and then whenever I click an anchor link it and reload it would load completely (hero section and all). Now on Safari, I experienced that no matter what order I clicked links and refreshed if I was on an anchor link and refreshed it wouldn’t render anything above it.

1 Like


Bug is consistent in Safari, every refresh has the same issue, but on refresh, page renders in Chrome properly

No explicit update from Webflow, but I’ve checked and it seems that you guys fixed this, so I’ll mark as solved

1 Like