Recent MacOS and iOS update killed video autoplay

I am using the Finsweet Auto Video attribute to start playing the infographic videos in the “Services” section only when they are scrolled into in view, but with the recent update to MacOS 14.1 and iOS 17.1 it shows a play button on the video, very similar to how it happens when power saving mode is enabled on iOS.

I tried to apply this fix for power saving mode on iOS but it only fixes it for my iPhone running an older iOS in power saving mode, but any device with the recent iOS shows a play button even with power saving turned off .

On Mac OS 14.1 autoplay works in Chrome but in Safari it also shows a play button.


Here is the website
Project read-only link

I tested with Safari Version 17.1 (19616. on MacOS 14.1 and the videos played just fine. There is a delay but that appears to be your implementation. Either way this would not be a Webflow issue.

Thanks for testing! Yes I realize its not a Webflow issue, it was woking great before this iOS/MacOS update. I mostly created this thread in hopes that @Finsweet will see it and maybe make an update /workaround for this issue.