Radio buttons in form are not responding when clicked, and I Navbar overcrowded on mobile

Hi - okay first off, this is probably a really easy fix but I’ve been trying for the last two days to do it with no luck.

  1. The radio buttons on two of my form pages aren’t responding properly when fixed. For one of them (link), I want to set it up so users rate the topic on a scale of 1 to 5, and they can only select one out of the five options. Also, I can’t figure out how to change the color when a radio button is selected? The problem happens on the submit rating page but also on this page for signing up. I can change the ‘hover’ and ‘pressed’ states, but the state that it shows once it’s been selected is still the same as it was from the template that I cloned.

I if you have a better way to do these 1 to 5 ratings in a form that isn’t the plain drop down (that’s annoying for a user to have to do especially since the form is already pretty long), I’m all ears.

See screenshots attached for reference.

  1. In mobile (landscape but especially in Portrait) the Navbar is very crammed with the different login/signup buttons. I can’t figure out how to move those buttons to the Menu Icon drop down list when viewing the site on mobile. I’m out of screenshots but you can see this in the read-only link if you switch to mobile view. Does anyone know how I could fix this?

These are probably very basic asks, and I looked through the forum for people with similar issues but couldn’t find anything. If there are any forum posts about solving either of these issues, please let me know.


Here is my site Read-Only: Dyversifi