Problems after background video implementation

Having several problems with my site interactions and effects after implementing background video. I’ve detailed some of the issues in my post below, but I’m also having issues with my class “Nav Link” under “Navigation.” These links are supposed to transform 5 pixels up when hovering, and work fine in the designer, but don’t work when published.

Also, my fixed navbar doesn’t appear on scroll anymore, as described below. Any help would be appreciated!

Continuing the discussion from [Tutorial] How to add a Background Video:

This preview link does not work. :frowning:

This link works, sorry!

I’ve figured it out, but all the changes are too much to show in screenshots so I recorded a screencast video, just uploading now… one moment :slight_smile:

Here it is:

The video shows me figuring it out from the start, so I flip between preview and editor mode a few times.

Basically you need not have all those index values on your elements or sections. You should have a value of -1 index on the video, and you needed to drag “Header Fixed” to be the very first element in the navigator.

The video shows every step until it is working a-okay :smile:

Hope it helps!

That worked perfectly @jaidenraleach, thank you! I’m also wondering why the hover state on my “Nav Link” under “Navigation” stopped working upon publishing. It works fine in the Webflow Designer (the first screenshot below), but doesn’t work when published…

Glad it worked @jordanshotwell! Looking into the Nav Link issue, hang tight.

Okay so this Nav Link behaviour is odd, the only thing that seems to fix it is the following:

-Drag a new text link into the bottom navigation
-Link it to the page section it belongs to
-Add the same “Nav Link” class to it
-Do this for all of them (About, Services, Portfolio, Team, Contact)
-Then Delete the original links

Everything then works fine :anguished: not sure why you have to do this, looks like a silly glitch is all.

Odd. Thanks for all your help @jaidenraleach!

1 Like

Very odd. Silly glitch is my guess. My pleasure @jordanshotwell!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.