Streaming live at 10am (PST)

Problems adding embed to webflow site

Hi all - I’m having trouble connecting search embed to my CMS even though I’m pasting it into my Collection Item. Would love any advice on this. See picture attached

Here is my site Read-Only:

Hi Eloise :slight_smile:

On the Jet Boost side there should be a place to put the URL (to the page the URL is embedded) and a “test button”. If things are not configured correctly when you push the “test button” you will get an error message in red that will tell you what you have done wrong. Have you tried the test button? What did the result say?

Hi Mark! Yes the error message says ‘Couldn’t find a Collection List Wrapper with the jetboost-list-wrapper-ol3o class. Make sure you’ve added it to the Collection List Wrapper element, not the Collection List.’ and for the collection Item embed: ’ Couldn’t find an Embed element containing the provided code’

It looks like I’m doing everything right so not really sure what’s happening here

Right :slight_smile: I don’t think you are far away from getting this sorted.

In the navigator you’ve got the “section”, then the “container”, then the “collection list wrapper”.

When the error message says “it couldn’t find a collection list wrapper” its talking about the “collection list wrapper” element here.
What I would suggest you do is to give the “collection list wrapper” a new class name, something like “playcare_list_wrapper” or something you would understand. Once you have named the wrapper then add jetboost-list-wrapper-ol3o to the class so its a combo class. It should look something like this:

This should (hopefully) fix the first error.

Try doing that then test it and lets see what it says :slight_smile:

(I’m no expert but I literally had to do this last night and work my way through the error codes so hopefully this helps :slight_smile: )

Thanks Mark! I tried that but still getting the same error message :persevere:

Okay :slight_smile: I would suggest you touch base with the Jetboost help if you can, they would probably be able to walk you through it.

But just check to see if the URL for the test is the correct one (not linking to the designer but to the published URL) ? Have you published the site or republished after making the changes?