Problem with Responsive menu

Although it works fine in the webflow designer after exporting the code it no longer works.

The responsive menu opens but I can’t click to a new page and the hover functionality is missing too. Plus no hand to show it is an active link. It was all working on previous exports.

I reset all the links but that didn’t work.

Help! please

Here is my site Read-Only:
(how to share your site Read-Only link)

Here is a link to the uploaded site to view how the responsive menu doesn’t respond:

In the read-only link I posted you can see it is working fine in the webflow designer

Try setting the nav menu z-index higher than the pages content.

Thanks very much for replying, I have tried what you suggested but still no working menu.

Strange it works when published to webflow but otherwise not. Driving me a bit nuts now.

Hey Connor,

Looks like the problem was 2 small pieces of custom code - google analytics and clicky disrupting my menu.
Discovered thanks to mistercreate on the forum, webflow staff from St Louis, Missouri.
I really appreciate your response, thanks again!

1 Like

ps I appreciate your idea with the z-index, you were not the only one to suggest it and I understand how that might have been it

I use webflow because I sure am not a coder!

1 Like