Problem with downloaded video and code…


First up, sorry if this is in the wrong section but wasn’t too sure where else to put it.

Having a problem with an mp4 video that was uploaded to Webflow for use in a site. In the published webflow site it works absolutely fine.

I downloaded the exported file from the browser which is called :


and uploaded it to my server (I will when ready be uploading all of the Webflow site to my own server and not using the Webflow hosting as I will end up integrating the templates with an external CMS at some point in the future).

Using this code :

<!DOCTYPE html>
<title>Autoplay Test</title>
<style type="text/css">
body {
	background-color: #000;

<video autoplay playsinline loop muted>
<source src="" type="video/mp4">

<!-- <source src="58889897175c717e43f8742b_FreeSmokeYoutube_1-transcode.mp4" type="video/mp4"> -->


Where I am linking directly to the file hosted on the Webflow servers it works fine, if I comment out the working video source and instead un-comment the source which is a direct link to the exact same file but which is instead saved on my server then nothing loads / works.

The link to the page is :

Not really too sure why this is happening though. I can see in the developer console in Safari that it isn’t finding the resource but that makes no sense as it is definitely there :wink:

Any help with this would be greatly appreciated.

Many thanks.

Best wishes,


Looks like it is autoplaying. Is your browser set up to play videos?

Hi Sam,

Yes the browser is fine with video. As mentioned above the exact same code works fine when the video is linked to from the webflow CDN but as soon as I link to the exact same video on my server it doesn’t work, autoplay or not.

I thought it was my encoding (as I was originally trying with a video from my hard drive) but this proves that it’s not that as it’s the exact same file downloaded straight from the webflow CDN.

Really not too sure what’s going on?

Best wishes,


I mean it is working as intended on your server, not webflow cdn. That site is hosted elsewhere right?

Hi Sam,

Thanks for looking at this some more for me. Sorry but I’m not quite sure what you mean.

What I’m saying is that with the code on that page pointing to the CDN video then my browser shows and plays the video just fine. If I then comment out the video source which points to the Webflow CDN and uncomment the video source that points to my own server [page is currently coded to do that] (same video file though, just downloaded from the CDN and uploaded to my server) then it doesn’t play or actually even load.

An image here showing what I’m getting in the Safari developer view although I’m not entirely sure what it’s telling me :wink:

Thanks again for looking at this for me.

Best wishes,


Looking at your image above then the video is obviously playing for you from my server so not really too sure why it won’t do that for me?

The CDN version works absolutely fine so I’m a little stumped as to why something from my own server won’t work?

Do you by any chance understand that developer output from Safari at all?

Many thanks,


Unfortunately still having a lot of problems here with this one. Have now noticed that if I just paste in the link of the mp4 video on my server directly into say an iPhone browser then it comes up with the download file page on the iPhone.

Typing in the CDN link then there video plays like it should. Definitely something a little hicky going on somewhere so going to get in touch with the web host to see why that’s happening.



Looking into this more I’m certain that there’s something awry on the server regarding this.
I took a video file, uploaded it to the server and tried to load it directly in a browser.
No go!
Uploading the exact same file in the exact same way to a different server (same host) and that plays fine in my browser which tells me that there’s nothing wrong with my browser or anything I’m doing.

I don’t suppose anyone could check this link for me could they?

In that page there are two video elements. The first one has a blue border around it and the video src is set to the video file on the separate server.

The second video element src link is set to the exact same file but on the same server that the html file is on.
On every single browser I’ve tried (12 in all now!) and via private incognito windows and also via and even running through VPN’s just to make sure it’s nothing my end.

None of them load the second video file, ever!

If anyone here is on a Mac and could possibly load up that URL and let me know if you see the video in the green bordered DIV then that would be great thanks.

I’m so close to 100% sure that I’m not doing anything silly but just want to make sure. Also checking in developer tools it doesn’t show the green video as loading and also in my network monitor (separate html page with just that video link in it) there is no loading activity at all.

Really need to figure out if this is a server issue so if anyone knows how I can debug this any further I’d be really really grateful.

Many thanks,


Seems like this is an external hosting issue, sometimes either video plays, and sometimes both play. It also may or may not have to do with cloudflare. Perhaps transfer to another webhost, since the video hosting from webflow is fine?

You’re absolutely right!

Just found out that the host was running Cloudflare on there. I’ve never ever turned that on but there is an option for using it in the control panel and it is automatically turned on. Not very happy about that at all!!

Will be having words with them about turning something on without my knowledge. This has wasted hours and hours of my time.

Thank you so much for looking into this more for me it really has been very highly appreciated.

Turning it off and emptying caches now has it all working.

Best wishes,