Problem With CMS URL's

Hello everyone,

I have encountered an issue that has prompted me to seek assistance on this forum. Despite sending three emails to the support team over the course of a month, I have not received a response, which I find quite disappointing.

The issue I am facing pertains to CMS (Content Management System) items. Specifically, I have created a blog, and on my homepage, there is a slider that displays the blogs. Users should be able to click on a blog item within the slider to access the full blog post. However, when attempting to do so, I am consistently redirected to a 404 error page.

I have tried two approaches to resolve this issue:

  1. Creating the slider without using CMS items and manually directing users to the appropriate URL.
  2. Using CMS items within the slider and attempting to redirect users to the respective CMS item URL.

Unfortunately, both of these methods have failed, leading to the same 404 error page. I have also taken the step of unlinking the CMS items from a “Blog” folder and modifying the redirect URL, but this action did not yield any positive results.

I am reaching out to the forum community in the hope that someone may have encountered a similar issue and found a solution. At this point, I am inclined to believe that the problem may be on Webflow’s side.

Any assistance or guidance on resolving this matter would be greatly appreciated. Thank you in advance for your time and support.

Hey Mitchell, welcome to the community forum.
You’ll need to share a few details if you want any help;

  • Your readonly designer link, generated from the page where you have your slider
  • A published link to the same page
  • Details of where to find the slider if it’s not at the top of the page
  • Details of how you build the slider - Finsweet CMS slider lib?

That should do to start.

Hi memetican,

I’m not too sure what a readonly designer link is or what you mean by Finsweet CMS slider lib. I’ve used the slider component provided by webflow and customized each slide to hold a CMS item.

Read Only Link: Webflow - The Asphalting Company

Published Link:

Location: Bottom of the page under “Out Latest Blog Posts”

Published Link to a CMS Item:

Perfect, you found it.
You currently have publishing turned off for your blog collection page.

Thank you so much! Every-time i have an issue it’s always something so simple.