Possible bug with link block?


@thesergie @sabanna @cyberdave @brryant

I’ve added added a div to my site “Other servies section near the bottom” which when you hover over the div the background changes color as well as the text. Now I wanted everyything in that div to be a link so I added a link block and added everything inside.

The background colour changes as it should, but the text isnt changing colour to white?

Hope you can help…


If you are adding elements into a link block you should change the hover state for that link if you want it to change color on hover.


Thanks for the reply, I did change the text colour on hover on the link block, but this doesn’t seem to work.

Best regards,

Hi @Matty, this seems like strange behavior. It could be a bug, but I’m not able to say for sure without more info - can you please include a screenshot of the behavior you’re experiencing and also of what you’re trying to achieve so I can take a closer look?

At first glance, i would remove the hover states from the div and instead add the hover states to the link block.

Posting guidelines can be found here: Posting Guidelines for the Design Help Category

Thanks in advance! :slight_smile:

In that case we need more information. Can you show a before and after screenshot of what you’re referring to since it’s not obvious.

Thanks both for the reply,


I’ve tried it on multiple brousers my currently I’m using Chrome Version 46.0.2490.80

The page on question is the hair page under the other services section.


This is how it looks before any hover moment.

Now when I you hover over the link block it shoud add a background colour as well as change the text to white. so it looks like the following;

But instead when I hover over the link block it does this, which as you can see the text isn’t changing to white when you hover over the link block.

Hi @Matty, Thanks for the screenshots! super helpful :slight_smile:

It appears that your pseudo states settings are conflicting with each other. Try the following:

(1) Remove the pseudo states from the link block AND all it’s descendants
(2) Remove the font color setting from the “other-services-header”
(3) Add the font color AND background color pseudo state to the link block

This works for me - if you need more assistance, just let me know and I can provide screenshots for each step. :slight_smile:

Thanks @thewonglv for taking a look,

That seems to have done the trick! I thought its most likely something I would have done wrong!

1 thing tho, when I made those changes its made the dark box x2 as big as it should?

Best regards,

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.