Possible bug, open graph image not working

Hi there!

My company is launching a new revamped academy today on our site. I am trying to create social media posts to push to this academy but when I post the link in LinkedIn it is pulling my previous open graph image rather than the new open graph image.

I cleared my cache to ensure this wasnt the issue.

Here is the page I am trying to link to: https://www.appcues.com/user-onboarding-academy

Here is the open graph image in my webflow settings

This is the image that is being pulled into linkedin:

Im not sure if this is a bug or if im doing something wrong- heres my sites read only link:

Thank you!

Here is my site Read-Only: https://preview.webflow.com/preview/appcues?preview=843cb62ebc522e7851d8142fffb028e4

I don’t think it’s a bug. It’s more likely to do with the how specific platform ( facebook, linkedin, etc ) is scraping opengraph resources. For example facebook has dev tools that forces to re-scrape.

Possible fix is - before posting - if it pulls from old resource, then cancel the post, and try again - generally within 2-3 tries ( scrapes ) it will pull the current one.

Example after - second try

Let me know if it works.

1 Like

Thank you so much I will try this! I just tried on facebook and it worked perfectly (i see you just tried too!) thank you so much for explaining this better to me, im glad it know it wasnt a webflow bug and wasnt something I was doing wrong. Thank you!!

@Tanya_Higgins @Throatscratch Open Graph needs to be debug and scrapped.

Facebook crawls your site and grabs OG data. When you change it, you need to go on their debugger tool to force a new scrap. Why Facebook? Because they originated OG.

Look how I do it for your site and how the data change: (it seems it had the good data)

Ok so in this one, FB did have the correct data. The tool is useful to force it, in oder not to wait.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.