Position sticky in grid — Saaaave me plz

Dear Weblow community

I am going absolutely crazy on position sticky, of course, one of the last things I am working on for this page. I looked through other articles but did not find the issue.
The left column, that will contain a featured blog-post, should be sticky.
But for some reason it will not work. There are no set heights, no overflows:hidden,
I aligned everything to the top,…

So I try to make “blog_item” sticky.
This can be found in section-news > container-large > blog-component > blog-grid > main-list.

Thanks in advance!

Cheers
P


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

It is easier to find out te issue/solution if you share your Read-only link.

Hi Codenee

I thought I did, in the footer of the message.
Anyway, here it is again:
https://preview.webflow.com/preview/heavn-relume?utm_medium=preview_link&utm_source=designer&utm_content=heavn-relume&preview=01ad619c6e23999cf9fc5bbc88d90e90&workflow=preview

Hi Phil, the mainlist is to short to scroll. If u set the sticky on mainlist and remove sticky from blog item, it will work :slightly_smiling_face:

Thanks for checking!
I thought so too, unfortunately, it does not work.

Tried:

  • Setting a height to main-list
  • Or setting the main-list as sticky and not the blog-item
  • Or Setting the main-list and blog-item as sticky
  • Or adding articles at the right so the height of the main-list grows in height

It’s probably something really stupid we are overlooking.

It worked with the settings I had.

So just to make it clear:
You put the position:sticky on the ‘main-list’, with a few pixels top and it worked?
Did you remove it from blog_item? Or do you keep blog_item the same?

Thanks in advance

I removed it from blog item. As well i removed overflow hidden on the main-wrapper. My fault, forgot to mention that. See image below:

Mucho gracias!!
Or should I say, dankjewel?

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.