Pointing Webflow to my Wordpress registered domain address

Hi all,

I followed the instructions in Webflow’s How to Connect to a Custom Domain video and managed to change my A settings successfully.

But I can’t seem to alter my CNAME setting in a way that points my Webflow site to the domain name that I own (domain name registered through Wordpress).

On Wordpress, it’s showing a CNAME setting for *.okrabranding.com (with the asterisk) and I can’t edit this setting. I’ve added a new CNAME for home.okrabranding.com, because trying to add www.okrabranding.com only points it to www.www.okrabranding.com (wtf?).

So, right now, I’ve managed to point my Webflow site to this address: home.okrabranding.com, but I can’t get it to connect to www.okrabranding.com

Is there any way for me to connect my Webflow site to www.okrabranding.com?
What do I have to do in order for me to use www.okrabranding.com for my Webflow site?

Thank you all in advance

1 Like

Hi there,
Have you fixed the domain pointing?

Hi Gary,

Yes the domain pointing has been fixed.

What I did was, I switched my registrar from Wordpress to GoDaddy. GoDaddy is more flexible with its DNS settings and I was able to do what I set out to do.


Awesome! Glad you got it. Take care.

Hi Gary, so is there a way to do what Okra_Branding was describing initially? Running into the exact problem right now… Thanks in advance!


Not sure about Wordpress, but if you’re wanting to use GoDaddy (which I use); then it’s best to purchase the domain on GoDaddy and close the domains from the Wordpress registrar.

It’s always best to cancel a domain on the current registrar and buy it again on another. I’ve tried many times to switch it with time left, but its a hassle. You should purchase the same domain again, it’ll cost a little extra but its still worth avoiding the hassle.

Hope that helps.

Thanks for the quick response. I’m trying to cancel the domain from Wordpress, but since I bought the domain for a year, its saying that it’ll remain active till the year is up. Is there a way to get around this?