Pagination Works on - Not on custom domain

I have tried figuring out for the past 4 hours what is causing the pagination to break - 0 success.

Maybe someone of you would know why the pagination works here: Style Guide

But it does not work here: Style Guide

When clicking “Next” no new items are shown.

Here is my public share link: Link

Hi Christoph,
looks like you could resolve the problem?

It works for me on booth versions.
If it’s not working on your side try deleting your browser cache.

lmk if you need any additional help :slight_smile:

Thanks for the reply, Julian!

No it is still not resolved.

I deleted my cache and also used a different browser.

But with the custom domain page (Style Guide), when you press the “next” button, the collection items stay the same and there is no “Previous” button. Whereas on the non-custom domain they change

Still have not resolved the issue in case someone can help.

Hi [Christoph]

I have the same issue. It doesn’t work in the live website.

Where you able to fix it?


I also had the same problem, but in my case this problem was caused by using Cloudflare Pages as a proxy between domains, because I did not send the query params to the proxy address, and the problem was solved by add the query params.