Streaming live at 10am (PST)

Page redirecting by itself

Yes and Done! Thank you!

Thanks Denise,

forgot to ask you to republish the site in webflow. :crazy_face:

Of course! Duh! Sorry about that. :slight_smile:

Ok. One more thing.

Can you ‘un-publish’ the site, then ‘re-publish it’

Sorry for the to and fro.
Thanks
Keiran

Yes! This has been done!

Ok…sorry about all the back and forth.

Here is a couple of links to other posts with similar issues regarding changing slugs.

You asked if there was a need to ‘update permalinks’ (as per Wordpress), the equivalent in Webflow is the 301 redirects:

I was hoping that the unpublish/republish may have solved the issue, but it appears not.

Sorry about that.

@vincent Is there anything that being missed here?

Regards,
Keiran

I thought that the 301 redirect was a great idea… but when I added it, I got this warning:

A redirect from /parent-portal/parent-portal to /parent-portal/parent-portal-home creates a redirect loop.

Hmmm…and round and round it goes!

Ok, let’s see if @vincent can throw some light on the situation.

Are you under a deadline to publish a live site?

I’ll be ready by mid-week to have the client review the site. I can tell them that they’ll need to wait to review the portal, if needed. Thank you!

Why not copying all the content of the page into another new page, then delete the page, then create a new one with the good slug, paste back the content and see from there? Don’t fight, cheat!

2 Likes

Well, there you go! Works like a charm.

At first, I was trying to figure out if I was doing something wrong or if it was a bug. Thanks for your support on this issue, knk and vincent!

1 Like

Awesome!!

Thanks Vincent.

1 Like

I never encountered this issue. If you get caught in something that looks like a server or a cache is trying to outsmart you, going around may save time. I’m using 6 browsers because sometimes I don’t trust a cache flush :man_facepalming:

That was a bold guess, happy it helped you really!

Hi, can someone please explain why this is happening? I am having the same issue here. Have a go-live tomorrow morning. I tried Vincent’s strategy, it did not work. This is my first post, what is needed to get help on this?

1 Like

Hi all, I’m also having this problem and @vincent 's solution isn’t working.

In my case, I created a page with slug called, let’s say slugName1
I then created an alternative layout and called it slugName2
I decided to go with the new layout, so deleted slugName1 and then renamed slugName2 to the original page slugName1

Now, I can’t load slugName1 – it just redirects to slugName2 which doesn’t exist as a slug, because I renamed it as above.

Please help! Tried clearing browser cache, incognito mode, unpublishing, etc.

Ok - not sure why I never saw this before but amongst all the fiddling I had an error pop up saying a URL couldn’t be created, with a link to ‘manage redirects’, from where I was able to solve this.

You can access these from the Site Settings panel, under the Hosting tab. Hope this helps someone else!

1 Like

You should not have to set a 301 redirect to do this.

It’s possible you were still seing the content of your cache.

Demo:

Thanks Vincent, to clarify, I didn’t have to set a 301, I had to remove some that had been created automatically

They’ve been created automatically just by you fiddling with your page settings and slugs? I didn’t know Webflow would/could do that…

Certainly seems so! I definitely didn’t create them intentionally :man_shrugging:

A guess – does Webflow maybe create a redirect when you rename a slug for an existing page, to catch references to the old URL?