Page is loading too slow

Hi, I have a pretty simple page LeadIQ | Book a Demo, recently I did minor design changes to it. But for some reason this seems to have caused the page to load incredibly slow. None of the other pages have a blank white screen that then has all the content pop.

I’m not quite sure what’s causing this, as the page is not really heavy.
Can you please help.


Here is my site Read-Only: [LINK]1
(how to share your site Read-Only link)

Hey Daren!

Thanks for sharing.

It looks like you’re using Google Optimize?

The white screen/delay in loading is being caused by Google Optimize. You can test this by removing the tag from Project Settings > Integrations > Google Optimize and see if it fixes the issue.

Implementing Google Optimize in your project can cause additional loading times. Currently, a fix for this issue is not on our product roadmap as this integration is built by Google. Hopefully there will be an update in the future, however, we are unable to give a timeline on a potential release.

Google Optimize causes the slow load times because of the way they built the implementation. The way that Google Optimize has built this integration is so that the anti flicker code can work in the background to populate your data while the site loads content.

If you are looking to manage the implementation without using Webflow to add the code so that you can control as you prefer, then we recommend removal of the Google Optimization from your Project Settings, and then implement it with your own code in the project code section (remove the Google Optimize from your project settings).

You can then implement it with your own optimize code in the project with custom code. Here is some information on how to implement custom code into your Webflow project:

Hopefully that helps!

1 Like

Thank you for the clarification!

1 Like