One dropdown menu works, other doesn't?


I have a dropdown menu called IT Services, but if I click Open Menu in the designer and try to edit the inside content, it immediately closes again. So, I can’t change the text inside. The other menu works absolutely fine. I’ve also tried to just unhide it temporarily and then adjust the text, but after that it won’t work anymore in the live website. I’ve also tried going in through my mobile version of the dropdown menu, but as soon as I click it, it immediately closes. Again, other menu works fine and to me, it seems all setting are equal.

Any ideas? I’m stuck and haven’t found similar situations on the forum.

Would be greatly appreciated.

Here is my site Read-Only:
([how to share your site Read-Only link][2])

Can someone please help? It is a MASSIVE problem to me and I have no idea how to fix it. It is causing me a great deal of trouble on a daily basis. I’m stuck.

I am still desperate for help with this. Can someone from Webflow please take a look?

Still stuck on this =/ How can I get a hand?

Should I just access Webflow support directly for this?

Hey @LouisMSP, you could temporarily change the display for that “Dropdown List” element to Block instead of None - that way you’ll be able to see the menu to make the changes you want to make.


Hi blake,

Thanks for your response. I appreciate it. The weird thing is that once I do that (and hide it again later), the dropdown menu breaks completely. Otherwise, I would have used this method in the past.

That might be a clue to what’s wrong with it? Seems unusual for this to be bugged, it’s likely a design thing. But I guess it could be.

Again, thanks. You’re a champion for helping out.

Warm regards,


Hmm, it does seem like something strange is going on there. It could be helpful to reach out to support.