New Home page not working properly

This is my website https://www.practisis.com/

I changed the hompepage, but the issue I get is that when I click the navigation logo that should take me to the homepage, it gets you to https://www.practisis.com/old-home

How can I correct that? I don’t see a place on the navigation logo

the best way to get help is to follow the forum post guide.

When posting please:

  • Required: Share your project’s Read-Only link and live site’s Published link
  • The read-only link is a special URL generated in the Dashboard to allow others to view your project in the Webflow Designer. How to get your project’s read-only link?
  • The published link is the webflow.io subdomain where you can view the live site with custom code running. It is IMPORTANT to share this link, as custom code (eg. javaScript) does not run in the Designer.
  • Describe issue in detail including what page, section and/or element is localized
  • Upload as many screenshots as possible or provide screencast videos to help others help you faster
  • Add a description and/or post a link to a working example of what you’re trying to achieve
  • Reply to users by tagging using the @ sign followed by their forum username like this: @forumMemberName

You’ll need to select and update your old home page links directly.

Select the link, then you can connect it to your homepage, or if you want you can set it to a direct link of /, which makes it easier to swap home pages later.

update the link value to only go to /

You may also need to set up redirects

if you will read comments you will see that It was posted by @memetican