Need help with search results page!

My search results page is completely bugged. I accidentally deleted the default template and now I cannot put any text blocks or links on the search results wrapper/list/item, so I have nothing showing there at all. I can only put things inside the empty state. I don’t know how this happened. I had a fully complete search page yesterday but it vanished and I can’t find it in backups made 3 hours ago. With older backups I will lose a lot of progress and that isn’t an option. Please someone help me to reset the search results page!

Also the read only link does not show any utilities pages so not sure how I can show this problem. Please help me :cry:

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi @A_K

Thanks for posting. I’m happy to take a look at this for you to see if I can help.

Can you please share your Read-Only link? :slight_smile: (I’m able to access the utility pages as staff/admin)

Hi Brando, thanks for the help! Here is the read only link : Webflow - GIR

Hi @A_K

Thanks for sharing.

I did some more testing on this end, but I was able to add elements to the search results without issue:


If you are seeing other behavior on your end, can you send me a screen recording of what you see (CloudApp or Quicktime work well).

If you still see the issue can you please try the following:

Thanks in advance!

Hi Brando, I have tried this several times but it just refuses to work on my end. I have attached a gif for you to see the problem. Is there any way at all you could just add some text and heading elements so I can continue from there? I would be incredibly helpful. Thanks!

Note : I have tried this in incognito mode as well, but the problem still persists. I think something must be broken on my end.

Ah I see the issue now!

In order to add more elements to the search results you’ll need to be on the default here:

When you are the “no results” view, you aren’t able to add more. I’ll chat with the team a bit more on how we improve the UX here as this isn’t explicitly obvious.

Hi Brando,

Unfortunately this still does not work. I clicked both the search results wrapper and the search results list and made sure that it set to “default” mode. However for some reason I still can’t add any elements to it.

Can you please reset this page? Is that possible?

Also, I can’t seem to add any style elements to the Search Result Item. I have tried incognito mode as well as safari on my mac. It doesn’t seem to work

Hi @A_K

I made a quick video here: Screen Recording 2018-08-24...

Can you provide a similar one showing and explaining the issue? ​Thanks in advance.

Hi Brando, I have made a video to demonstrate the issue : - YouTube

Thanks for the help.

Thanks so much for sharing the video — definitely helps show what the issue is. It looks like regardless of having the default view selected, the empty state is still showing on the canvas :thinking:

We’ll dig into this a bit more and I’ll post back here when I have an update for you.

Can you please open the Designer, try to add an element once more, then grab a screenshot of the console? The errors here should serve as a good starting place to start debugging this.

​Thanks in advance!

Hi @A_K

It looks like that video you shared isn’t available. Were you able to resolve this? If not, can you please provide the console screenshot please?

​Thanks in advance :bowing_man:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.