Streaming live at 10am (PST)

Navigation Symbol not working

Same issue here. Seems to persist whether it’s a part of a symbol or not. Other elements seem to copy paste just fine. It’s the nav link that’s giving me grief.

Thanks for working on this as always!

Hi @Riley @domo @yzhou

The issue seems to occur when there are existing sites that have no Navlinks inside the Navmenu or like @ON2Interactive there are only Dropdowns, (again, no Navlinks)

I’ve just tested a fix created by our amazing :webflow_heart: engineers which seems to do the job, and we will keep you posted as to when it’s live.

@justjoe you should be good to keep your jumplinks too :slight_smile:

I know how frustrating these bugs are in the design process so thank you so much for your patience and understanding :pray:

2 Likes

Thank you! As a temporary fix I added a navlink to my menu before copy and paste. Keep in mind, after this is done, I can’t remove the navlink from the new menu.

Capture

This will be a temporary fix for now. Thanks again for the help!

1 Like

Same here. Unlinked as a symbol and still not working for me on any of my sites.

I can confirm that my nav menu does have navlinks (and dropdowns) and still doesn’t work.

Thanks for that @Port_of_Folio, it it possible to share your read only link, or email it to mark@webflow.com so I can see if the fix will work.

Standing by for your reply :+1:

Absolutely:

https://preview.webflow.com/preview/sherrillfurniture?utm_source=sherrillfurniture&preview=38f933236fc2395f49ceddfc3d165fbd

I’ve unlinked the symbol on my homepage nav (doesn’t copy/paste) and symbol version on “New Items” page is same error.

Thanks for that @Port_of_Folio

So the links you have in your Nav Menu are not actually Navlinks they’re Link Blocks. So you have a Nav Menu without Nav Links which is where the issue is. (The fix should… well fix this)

A temporary solution for this…

  • Drag a new Navbar anywhere into your page.
  • Drag one of the nav links from the new navbar into your current one
  • Give it a setting of Display: None
  • You will be able to duplicate the navbar.
    (Delete the new navbar)

Video explanation:
CloudApp

I do appreciate this is not ideal, a fix is around the corner, we just want to make sure it’s A-OK before pushing it live.

Please let me know if you have any issues.

Ah! Sorry about that. I have my link blocks named “navlinks” and confused myself. This works now. Thanks… never apposed to hacking it :slight_smile:

No need! :slight_smile: Glad it’s working now :smiley:

My nav bar has nav links not link blocks but it’s still not working.

Read-Only Link >> https://preview.webflow.com/preview/stce?utm_source=stce&preview=bf2f1a4e6ba8a5c46a5cf38646b26f35

Hey @JustJoe The text span on the Vendor Contact link is being classed as a child of the Navlink ( I think) , which on this version is not allowed, although it should be.

The fix in question that I’ve tested solves this and will allow you to use the jump link once again.

Ok, so it’s two different things right? My issue is the jump link, other people’s issue is link block vs navlink? Both are creating the same error?

1 Like

reasons i do not know of, but i can’t seem to use my navigation symbol anymore on any page on my website. have been told it might just be a bug, but i keep getting the error message ( nav link cannot be placed out if its nav menu ).
if you can help please do

1 Like

Exactly that, they’re two issues inadvertently connected. Fix coming soooooon :slight_smile: :tm: :crossed_fingers:

Hi @JustJoe, @yzhou, @domo, @clinton & @ON2Interactive We just deployed a fix for the Nav Link and similar errors! Please let us know if you’re still having problems after refreshing the designer and working with your sites!

Thank you so much for your patience! Sorry for the frustration! <3

3 Likes

It works great thank you!

M

2 Likes

Great to hear! Thanks for reporting back @Mat_Griffiths! :blue_heart:

1 Like

Working for me! Thanks!!

3 Likes

All good… Thanks much!

4 Likes