Streaming live at 10am (PST)

Navigation Overlaps the CMS

Hey guys,

I need your help. I built a Menu in Webflow wich works great when I hover over it, but in the CMS Editor it always lies on top of everything else. You can see it in the screenshot.


This is not really comfortable for the client / a bit unprofessional. Do you know how to solve this issue, so that the normal state of the menu is closed?

Here’s my read only link:

Thanks for your help!

Hi @davidk77

A great looking site and really nice dropdown interaction you’ve created.

So to do this is fairly simple. On the content wrapper of the dropdown you choose display setting: none

Then in the interaction, you will add to the interaction display: block

When you preview, the site will hide the menus, and then as soon as you hover, will display block before continuing with the rest of the interaction.

I hope this helps :smiley:

Thanks mark for the quick answer! :slight_smile: That helped! I actually had to fiddle a bit more around with the animation (had to built in the hide / show thing into my interaction) but then it worked nicely and now it looks even more smoother! Thanks for your help, really appreciate it! :raised_hands: