Navbar won't stick at the homepage in Chrome browser

Hi,

My navbar won’t stick to the top while scrolling at the homepage in a Google Chrome browser. The strange thing here is that it works on other pages and also on a Safari and Firefox browser.
I tried multiple things (make it sticky and fixed, set the upper margin to 0, change the z-index) but nothing seems to work.

Can somebody help me with this?
Thanks in advance!


Here is my site Read-Only: link

And the website live: link

Hello @lot
I hope you are doing good

Watch this video: Header Quick Fix — Tella
Let me know if this works :raised_hands:

Hi Pravin,

Thank you for helping me!
Unfortunately, this solution doesn’t work for me. It does work in preview mode, but when I publish it, it won’t…

I hope you can help me further finding the solution

oo are you using some custom code?
Remove or comment them for a while and test if works

Keep me updated pls

HI @lot you have in your navigation setting for main viewport set nav wrapper position sticky but on bigger viewports you have set it to fixed you can just reset it to be sticky on all viewports. It should fix your issue.

Hi @Stan,

Thank you for helping me. Unfortunately, this doesn’t work either for me on chrome :frowning:
Also, the size of my screen doesn’t seem to affect the stickiness of the navbar, so I don’t think the problem lies there

Hi @pravinakajerry, I removed all the custom code I added in the home page and it works now!
Thank you very much

1 Like

Hi @lot no worry, It is strange that sticky didn’t worked for you as it worked for me on live page and you have it now set correctly on all viewports. I’m glad to see you have it solved. :wink:

2 Likes