Streaming live at 10am (PST)

Navbar - Links not automatically in hamburger menu


still very fresh with webflow. We are looking at an older design where we have to have a vertical navbar and use graphics in the buttons. What I don’t get now is that of my 5 navbar items (buttons) only the first two appear in the hamburger menu. So I started to add buttons to the hamburger menu but I can’t name them …

What am I doing wrong?

Hello @Ernesto

Could you be a little bit more specific, please? Just not sure what do you mean :confused:
Also, it would help very much if you could share read-only link to the project and point us to exact problem.


Hi, thx

just found the problem … user error. However, I do have the problem that we need to build a vertical navbar that located on the left side (see enclosed screenshot of the pre web flow project). We have done this by adding a table where the navbar is in the left column. However, when we move to a mobile layout things start to get messed up.

Any ideas how to handle this layout in a responsive situation?

Also, how do I enclose a read only link? Just copying the address from the browser?

Here’s how you share a read only link. Thanks! :wink:

Hello again, @Ernesto.

You do not need to use Row with Columns (I believe it is what you call “table”). It will be enough to make nav-links display: block (instead of inline-block) and set the navbar itself to position: fixed.

Also, may I know what the design idea for the mobile layout?


Great comment tried that and here the link

Regarding the mobile layout here is the link. If you use safari just enable developer menu and change mode to responsive design.


1 Like

So now we have moved the nav bar left, gave it a fixed width and height. The slider was placed in a DIV that has right alignment.

Works fine on Desktop and tablet, however on phone size layouts we have the two items on two lines. It makes sense, however it just does not look good. Any idea how we could make this look better?

This topic was automatically closed after 60 days. New replies are no longer allowed.