My website is not responsive in landscape mood as expected

can anyone guide or assist me what i can do to make my website correctly be responsive in all modes


Here is my site Read-Only: [LINK][1]

([Webflow - Property Central Website][2])

Hi Vipul,

Your question is too broad to answer- what problem exactly are you having with your responsive design at the landscape mobile breakpoint?

in landscape breakpoint its not working as it should be i have shared a screenshot below for the same
everything is got mixed up badly
all the different sections in one page are mixed

You have a number of size and position settings in play that will fight the browser’s ability to naturally flow your content.

The main ones I’m seeing is that a lot of your sections that are overlapping have vh heights that are too small for the content. In general, I’d remove those. You will find it easier to let the browser calculate the space it needs automatically.

You also have a number of elements with negative padding.

I’d clean those things up so the browser can do its job of handling your element flow more organically.

should i change vh to pxl or something else ? and i will workout on the second point you metioned

I wouldn’t set a height for those sections at all. Worry about your padding, margins, content sizing, and let the browser do what it’s good at.

1 Like

i tried it but i will try once more
thanks buddie

nothing is changing even i tried different settings keeping it in auto too
its weirdly placed in landscape mood and i want to host it but cant because
of this problem

You’re headed in the right direction, it looks much better.

but i did check in a mobile landscape it still same