Streaming live at 10am (PST)

Modal dialogues not working in dashboard (Google Chrome)

Whenever I click anything that initiates a modal popup (delete a site, upgrade my account, etc), the screen grey’s out, then nothing else happens. No dialogue appears, and I’m not prompted to do anything. I’ve tried it on both stable and canary release, and I get the same problem. It also seems to be happening on firefox on my computer as well.

I don’t have any other computers to test on, but if no one else is experiencing it, it might have to do with the fact that I’m running a Surface Pro, and Chrome seems to have some weird rendering glitches with high DPI screens. I’d say I’m just an edge case, but I can only imagine how quickly high DPI screens are picking up steam, and it’d be a shame if more people are experiencing the same frustration as me.

I’d really like to be able to use my dashboard without having to open up IE, but as of now, it’s broken.

I have no clue about your issue, but would you mind telling us about your experience with working in Webflow on a Surface pro? For a start, does the UI fits?


I can confirm that modals are broken on Chrome Canary. I haven’t tried on regular Chrome.

Ummm, the Surface Pro may have tablet features, but it’s in the ultrabook class, not tablet, as it runs Windows 8, not RT. It’s more laptop than tablet, and I run it plugged into a docking station with a mouse and keyboard, plugged into a second monitor, with the full, official Windows version of Google Chrome web browser, which I do believe is officially supported by Webflow.

Furthermore, my screen resolution is 1920 x 1080, which I believes also falls under your supported screen resolutions. The Surface Pro is no less a capable laptop, than, say, the MacBook Air. I have no trouble running Photoshop, Indesign, Illustrator . . . Heck, even Webflow’s actual UI works flawlessly.

Having said that, I can admit I’m a little biased. I’m a paying customer, so of course I’d like to argue that I’d fall under the support blanket. After all, you do have my credit card number.

Getting to the issue, it still doesn’t work when I disable high DPI, which I just tested today. I even disabled the Surface Pro’s screen and was running solely on the second display. When I click on the button to upgrade my account, the screen just “greys out” as if preparing for a modal popup. But I never actually get to see the popup. I can click on the grey overlay to return to Webflow, but that’s as far as I get.

As I mentioned, Webflow’s interface itself works well. It’s only the admin UI that is not functioning properly. I mean, that part should more or less should function as a basic website, not a “web app”. Modal popups are a pretty trivial feat when it comes to web development. I’ve never been to a website, where they didn’t work before on ANY tablet, phone, laptop, “android” (wat), or desktop.

I’m convinced that the problem can be attributed to an error somewhere in the CSS. Heck, I could even try to write a patch for you guys if you want. It should only take a couple lines of code. But I’m sure it wouldn’t be as clean as what you guys could come up with if you put your minds to it.

Please forgive me if this reply comes off as cheeky, it’s just that I don’t really appreciate receiving what appears to be a stock reply to what I believe to be a legitimate support issue. I love using Webflow, and it’s really changed my entire workflow in the best ways possible, and I’d love to continue using it in the future.

A big fan,

It’s been just as mind blowing as using it on anything, I’d imagine. Set your screen resolution to 1920 x 1080, and that’s about my experience. It’s a little cramped, but nowhere near unusable.

When I do need more space, I plug it into a second display and extend my desktop. By that point I might as well be using a desktop computer as far as my workflow goes.

In other words, it being a Surface Pro, doesn’t really affect webflow too much, other than the obvious benefit of being able to use it on the bus.

Hi @Eric_McFadden, sorry my bad, I mistakenly thought that surface pro is running full Win 8.1, so you are right, that is not a “tablet device” for example, like some other Windows RT devices, sorry, when I was doing some checking on Surface Pro, I thought I had read it was running the Windows RT.

Are you experiencing the modal issues with each use of Webflow on Surface Pro? We can open a support request for you at to investigate this more to find out what it is that is causing the problem for you. Cheers.

@vitaligent and @Eric_McFadden, thanks for the info and the updates. I will investigate this issue with Surface Pro and provide update when I have more information. Thanks !

Hi, so I did do some checking on this, and we have put the Surface Pro device, into the same category as other devices where we have similar issues, such as Chromebooks, Macbook Air laptops, and a variety of desktop machines. We are working on getting a SurfacePro tablet for performance testing, but currently cannot guarantee any level of performance on that device.

Our recommendation, just so that you get the best possible experience, is to continue to use Surface Pro if you wish, and we hope that all functions do work, however if you run into a situation where you have a mission critical thing to do in Webflow, that you use the Desktop environment for that.

As we can confidently support other devices, we will update our system requirements.

I hope that can bring some clarification on this and if you have any additional questions, please let us know. Cheers, Dave

We’ll take a look and see how we can fix the modals. @Eric_McFadden

1 Like

I have a Surface Pro 2 128GB… and a Dell Venue Pro 8 - 32 bit (64GB) and 11 - 64 bit (128GB).

STRANGELY ENOUGH,… on the Dell Venue Pro 8

  • which has a resolution of 1280 x 800… Webflow works. Difficult to use with fingers… but works fine.

On the Surface Pro 2 and Dell Venue Pro 11… resolution 1920 x 1080…I get a message
“Your browser is too small. Please resize your window to fit this media query”.

All 3 on Chrome / Desktop Mode.

I do 1920 x 1080 - multi monitor - on a Mac Mini Server i7 and a Dells Window i7 with no issues… with Chrome.

Right click on the desktop and select “personalize”. Then, in the bottom of the sidebar, click “display”, and you’ll be taken to the settings where it says “change the size of all items” drag the slider to smaller, and hit apply. That should help your screen size problems with webflow on your surface pro 2.

Hi Eric,
This bug has nothing to do with Surface Pro/hardware, this is more of a Chrome (Canary) thing. And yes, we know Surface Pro is a full blown laptop, so as long as you’re using the physical peripherals, there’s no reason why anything should break for you.

We pushed a fix, let me know if you can see the modals now.


thx for Eric. I noticed Webflow now words on both the Surface Pro and Dell Venue tabs :smile:

Hi I’m experiencing the screen too small thing. I’m using a Yoga 900 convertible which has a higher than HD resolution. I can only edit mobile pages. I won’t buy a new laptop until next year so this is my handy go-to. What’s the restriction for exactly? Seems unnecessary.