Mobile responsiveness issue with interactions

Hi Guys

I’m having some real issues with the mobile version of my site. When I look at it on desktop, there are no issues and it works as I want. However once I check it out on my mobile, there are a number of issues. These issues are involving interactions.

  1. Once you scroll down the interactions aren’t smooth flowing like they are on desktop
  2. They seem to cause the page width to expand and the whole site messes up and you can scroll right, as well as just up and down

On preview mode on webflow builder, these issues aren’t apparent and I can’t seem to work out how to fix them. The site is currently live:

read only:

I appreciate your help

Many thanks

Here is my public share link: LINK
(how to access public share link)

Hi Williams, i had the same problem and in my case the solution was put the Divs with the overflow hidden as you can see in the picture. I hope that it’s a solution for you too.

Best regards,


1 Like

Hey Bradley @williamsbrad1994,

Try to add the first interaction in your Scroll into view as Initial Appearance instead of making it part of the interaction and tell me if you see a difference.

Try Gustavo’s @tato2278 solution.

Please, inform us if this solves your problem.

Best of luck,
Anna K

Hey Gustavo

Your solution seems to have worked perfectly! Thank you very much for your help :slight_smile:

1 Like

Hey Anna

Yes Gustavo’s solution seems to have fixed the problem.

Though your solution also seems like a viable option and is a way I will definitely look to improve upon my interactions in the future :slight_smile:
Many thanks!


You’re welcome Bradley.

Just make sure that the component with overflow :hidden doesn’t have a restricting height value that might hide some of your content.

All the best.

Exactlly Anna, you have the reason, I had to change a height options in some cases.


1 Like

Happy first anniversary with Webflow @williamsbrad1994

Thank you! Cant believe its been a year.

I didnt even know that myself so thank you :slight_smile:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.